
No layer or composition is an island – at least,
not in complex animations. In this lesson,
you will learn how to group layers and build

composition hierarchies, making it easier to create
and manage complex animations. First up will be
parenting, where one layer’s animation can influ-
ence that of others. After that we’ll work with
nesting and precomposing compositions: ways to
bundle together layers, keyframes, and effects into
one comp and treat the result as a single layer in
another comp.

Approaches to Grouping
There are three general approaches to grouping inside After
Effects: parenting layers together, nesting and precomposing
compositions, and applying expressions to individual 
parameters. Here is an overview of their relative strengths,
weaknesses, and uses:

Parenting: With this technique, you “parent” (attach) as
many child layers as you want to a parent layer. The children
remember their relationships to the parent at the time you
attach them. Any changes in the parent’s position, scale, or
rotation results in the children being dragged along for the
ride. The children may have their own animation as well, but
these are not passed back to the parent. To better visualize
this, image a person walking several dogs. The dogs may be
running around their minder, but as their minder walks down
the street, all of the dogs move down the street as well.

The advantage of parenting is that all of the layers
involved are in the same composition, which makes them
easy to keep track of. A disadvantage is that changes in
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Grouping layers to make them easier to coordinate.
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� Getting Started
Make sure you have copied the Lesson 06-Parent & Nest
folder from this book’s disc onto your hard drive, and make
note of where it is; it contains the project files and sources
you need for this lesson. Rather than use a single project
file, for this lesson we have provided several different
project files to make it easier to keep track of all the
compositions you will be creating and using.
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opacity are not passed along from parent to child, so you
can’t use parenting to fade out a group of layers together.
Effects are also not passed from parent to child.

Nesting: The process of adding a composition to another
composition is referred to as nesting comps. The nested
comp (often referred to as a precomp) appears as just
another layer in the second comp. You can animate, fade,
and apply effects to the nested comp layer as if it were a
normal movie file. The primary difference is that it is “live”:
You can still go back to the first (nested) comp and change
it, and those changes will appear immediately in the
second (master, or main) comp without the need to first
render the precomp.

Another use for nesting is that a single source comp 
can be nested into more than one master composition. 
The same source comp may also be nested several times
into the same master comp. By doing this, you can easily
change the original nested comp, and the change will ripple through to any
comp it is nested into. This is ideal for creating repetitive elements such as
 animated logos that may be used multiple times throughout a project; some
 animators may refer to this process as creating an “instance.”

Precomposing: When building a chain of nested compositions, ideally you’re
thinking ahead: You use several layers to build an element in one comp, then
use the result nested into a second comp. However, the creative process is rarely
that orderly and logical. You might build a complex composition, only to later
think, “You know, life would be easier if I could just group these layers into 
their own nested comp…”

Well, you can: The process is known as precomposing. You can select one or
more layers in the current comp and “send them back” into their own comp
(called a “precomp”) that automatically becomes a nested layer in the current
comp. It’s almost as if you planned it that way ahead of time. Once you do this,
as far as After Effects is concerned, there is no difference between the resulting
precomp and a normal nested comp.

Expressions: After Effects also allows you to connect virtually any parameter to
another parameter. This involves creating small pieces of JavaScript code referred
to as expressions. We cover expressions in the next lesson, but in short, basic
expressions could be considered a highly targeted form of parenting, where only
individual parameters are connected rather than all transform properties at once.
The big advantage is that you can connect any parameter you can keyframe –
not just position, scale, and rotation.
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In this lesson, you will learn several ways to group together layers to
make complex animations easier and to re-use elements multiple
times in the same composition.

� factoid
Family Trees
You can create parenting chains where one
layer is parented to a second, the second
layer is parented to a third, and so on. 
This makes parenting an essential tool in
character animation: For example, you can
attach a hand to a forearm, a forearm to an
upper arm, and the upper arm to a body.

� tip
Effects and Children
Effects applied to a parent are not passed
along to its children. To apply the same
effect to a group created by parenting, use
an Adjustment Layer (Lesson 3), or nest
their comp into a new comp and apply the
effect to the resulting layer.



Parenting
In this first parenting exercise, you will be grouping together two layers to make
it easier to animate them as a unit. In it, the “child” will keep its animation,
which will also be affected by its parent.

1 For these first two exercises, open project Lesson 06 > 06a-Parenting.aep. 
In the Project panel, twirl open the Comps folder, then double-click the comp
Parenting1*starter to open it.

Press 0 on the numeric keypad to RAM Preview this comp. It consists of a
movie of a globe rotating, and a Photoshop still image of text on a circular path.

For this animation, let’s make the text and planet scale up as a group, with 
the text rotating around the planet. We’ll then try to fade them out as a unit.

2 Select both layers, then press s to reveal their Scale followed by Sr

to reveal Rotation and St to reveal Opacity. If you scrub these values for
each layer, they will act independently of the other layer. Undo to get back to
their original state.

3 To set up a parenting group, you need to reveal the Parent column in the
Timeline panel. If it is not already visible, you can either right-click on any
column header in the Timeline panel and select Column > Parent, or use the
keyboard shortcut S$. We tend to drag the Parent column to reside along-
side the layer names, making it easier to read who is connected to whom.

The next step is deciding who the child should be, and “parenting” it to the
layer you want it to follow. In our case, we know we want to rotate the text 
independent of the planet. Therefore, it would be best if the text was the child,
so that its rotation will not get passed onto the planet.

4 There are two ways to assign a parent:

• Click on the Parent popup for the prospective child Text on a circle.psd and
pick its new parent – planet.mov – from the list that appears.

• Alternatively, click on the spiral icon (the pick whip tool) in the Parent column
for the child and drag it to the name of the layer you wish to be the parent.
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� Choosing a
Responsible Parent
When grouping together layers using

parenting, it is important to think

about who should be the parent and

who should be the child. 

A parent’s animation gets passed

along to its children. Therefore, the

layer that is going to be doing the

least animating often makes the best

parent – that way, the children are

free to run around the parent

without their animation being passed

onto the parent.

Use Parenting to make the text and planet
scale up as a group, with the text rotating
around the planet.
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4 There are two ways to
attach a child to a parent:
Use its Parent pop-up
(left), or its pick whip tool
to point to its parent
(right).



5 Scrub the Scale for Text on a
circle.psd; only that layer scales.
Return it to 100%, then scrub Scale
for planet.mov – when you scale
the parent, both layers scale as a
group. Note that the Scale value 
for Text on a circle.psd does not
change; its scale value is now shown
relative to its parent.

• Press H to make sure you are at 00:00, then click on the stopwatch for
planet.mov’s Scale to enable keyframing. Enter a value of 0%; both layers will
disappear.

• Move the current time marker to 02:00 and set Scale back to 100%, returning
both parent and child to full size. Press ( to make this an Easy Ease keyframe.

6 Now let’s rotate the child layer:

• Scrub Rotation for Text on a circle.psd; it rotates, but its parent does not.

• Press H again, and enable keyframing for Text on a circle.psd’s Rotation.
Return its value to 0°. 

• Press N, and enter 1 for Revolutions (Rotation’s first value). The second
keyframe should read 1x+0.0°.

RAM Preview: The text rotates as both scale up together, then continues to
rotate without affecting the parent.

7 Parenting passes scale, position, and rotation from parent to child, but
nothing else:

• Move to 10:00, select planet.mov, and press OSt on Mac (ASt

on Windows) to reveal Opacity and enable keyframing.

• Press N, and set planet.mov’s
Opacity to 0%: The text will still be
visible. You will have to fade out the
Text layer separately. 

In addition to opacity, effects are
also not passed from parent to child.
Go ahead and try adding an effect
such as blur to planet.mov; the text
will not be affected. This can be a
blessing or a curse, depending on 
what you are trying to accomplish.
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7 Unfortunately, opacity is not passed from the parent to the child so you can’t fade out
both layers as a group.

6 Nothing applied to the child – for
example, rotation or tint effects – are passed
along to the parent. 

5 As the parent (the planet) scales up, the
child (the text) scales up as well, by the same
proportional amount.



Parenting with Nulls
Sometimes it is not clear which layer would make the best parent. The solution
is to hire a babysitter: a null object. Nulls are layers that do not render, but other-
wise have normal transform properties such as position, scale, and rotation.

1 Bring the Project panel forward, open the Finished Movies folder, and play
Parenting2.mov to see what you will be building. Close the movie when done.

2 Double-click Comps > Parenting2*starter to open it. Then press S$ to
reveal its Parent panel.

Parenting Chain
3 When you start parenting, first build any sub-groups that make sense to
handle as one element. In this case, the number 9 and the planet form a logo.

Click on the Parent popup for Nine, and select
planet.mov to be its parent. Now when you move
the planet, the number will stay with it.

4 Let’s employ a null object to move the rest 
of the title layers as a group. Still at time 00:00, 

select Layer > New > Null Object; it will be added to the timeline. 

To rename the null, select it, type CSy (LSy) to open the Solid
Settings dialog, and type a name such as “Title Parent Null”, and click OK. In
the Comp viewer, the null will appear as a square outline. The null may be hard
to see, so temporarily turn off the Video switch for Muybridge_textless.mov.
Note that a null’s Anchor Point defaults to its upper left corner.

5 Since scaling and rotation happen around the parent’s anchor point, it is
important to first move the parent into the desired position before attaching 
the children to it. The center of the planet would make a good center for scaling
this group, so let’s borrow its Position value:

• Select planet.mov, type p to reveal its Position, click on the word Position
to select it, and use Edit > Copy. 

• Then select Title Parent Null and Edit > Paste. The top left corner of the null
will now appear centered over the planet. 
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4 Null objects appear in the Comp
viewer as an outline of a square, with
the Anchor Point in its upper left-hand
corner. Turn off the background layer
to see your new null more clearly.

3 The number 9 and the planet form a
logo (left), so use parenting to parent the
Nine layer to the planet.mov layer and
make a sub-group (right).

5–6 Copy the planet’s
position value to the null’s
position (left). Then select
and parent the remaining
children to the null (right).

1 Play the finished movie. You will use
parenting to animate the title layers and
the Planet 9 logo together as a group. 
(You will build the background animation
in the next exercise.)
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6 Time to parent the other layers. Click planet.mov to select it. Then
S+click on Season Finale to select layers 3 through 5. (Don’t select layer 2, 
as it is already parented to layer 3.) Then drag the pick whip tool for any of the
selected layers to Title Parent Null, and they all will become attached to it.

Animating the Null
Now that we have everything set up, we can animate the group. The plan is to
have them move forward to make the “9” logo and “Tomorrow” the heroes. 

7 Select Title Parent Null. Its Position should be visible; type Ss to also
reveal Scale. Move to 02:00, then click on the stopwatches for Position and Scale
to enable keyframing for these parameters, as well as set their first keyframes.
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� Parenting and Scaling
Scaling a layer past 100% normally

reduces its quality. However, the

Scale values for a parent and its 

children are combined before After

Effects calculates how to draw the

pixels for each layer. Therefore, if a

child has already been scaled down,

you can get away with scaling up its

null object parent without any loss 

of image quality for the child, as long

as the combined scale values amount

to 100% or less.

In Parenting2_final, we animated each of
the children independently, and added a
text animation preset to the Tomorrow title.
Muybridge images courtesy Dover;
background courtesy Artbeats/Digital Web.

7–9 Keyframe the null object to grow from
100% to 150% (left), and place the planet
logo at the edge of the Title Safe area
(below) at the second keyframe.
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8 Press F (apostrophe) to turn on the Action and Title Safe grids.
Make sure you position the text in a legal area of the screen.

9 Move the time marker to 02:15. Increase the scale of Title
Parent Null to 150%; the entire group grows larger and a second
Scale keyframe is created.

Then click inside the null’s outline and drag it to the left until the planet is
positioned just inside the Title Safe lines. The group will move together, and a
second Position keyframe will be created. (If only one layer moves, you acciden-
tally grabbed a layer other than the parent null; undo and try again.)

10 To clean up the title, fade out the words to the left: Keyframe the opacity
for Season Finale from 100% at 02:00 to 0% at 02:15.

Now that the major structural work is done, you can work with the children
without worrying about affecting the parent and the overall move. Animate the
planet, Tomorrow, and Season Finale child layers to your personal taste. Turn
the Video switch for Muybridge_textless.mov back on to see the title in context.

Our version is in Comps_Finished > Parenting2_final. We scaled up the
planet subgroup, slid in Season Finale, and applied a Text Animation Preset to
Tomorrow, all with staggered timing so that each would get their turn at being
the center of attention.



Nesting a Group of Layers
One of the more powerful features in After Effects is the ability to treat a compo-
sition as a layer in another comp. This process is referred to as nesting, and is a
great way to group layers together.

Creating the Wide Comp
1 Open the project Lesson 06 > 06-Nesting1.aep. Look inside the Project
panel’s Finished Movie folder and play Human Figure in Motion.mov: This 
is what you are going to make. You’ll start by building a wide comp that holds
multiple copies of the Muybridge human figure sequence. This wide comp will
be nested into a second comp that includes all the other layers.

2 In the Sources folder, single-click the sequence Muybridge_
[00-09].tif to select it. The top of the Project panel informs you
that its size is 270×500, with a rate of 10 frames per second (fps).
The sequence consists of only 10 unique images, so it was looped
10 times in its Interpret Footage dialog. Your first task will be
 creating a large composition to hold copies of this sequence. 

Select the Comps folder so that your new comp will auto -
matically sort into it, and type Cn (Ln) to create a new
composition. Enter the following parameters in the Composition
Settings dialog:

• Disable Lock Aspect Ratio. Set Width to 2300 pixels (more than eight times
the width of the sequence), and Height to 500 pixels (the sequence’s height). 

• Set the Pixel Aspect Ratio popup to Square Pixels.

• Set the Frame Rate to 10, Start Timecode to 0, and the duration to 10:00.

• Enter a name of “Figures_group”, and press OK.

Resize your user interface frames to give the Comp panel as much room as you
can, and set its Magnification popup to Fit Up To 100%. 

3 Drag Muybridge_[00-09].tif from the Project panel to the left edge of the
Comp viewer – it should snap into place. 

4 To help align additional copies of this sequence, let’s take advantage of guides
in the Comp panel:

• Press Cr (Lr) to Show Rulers.

• Click in the top ruler, and drag downward: A blue guide line will appear. Place
it even with the top of the comp’s viewing area. If you have the Info panel open,
drag until it says the guide is at 0.0.

• Verify that View > Snap to Guides is enabled.

The final composite includes multiple copies
of the Muybridge “walking man” animation
in a nested composition.

4 Turn on the Comp panel’s rulers and
drag a guide down to the top of the viewing
area. Placing a guide at Y = 0 will allow you
to easily snap layers to the top of the comp.
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2 Create a large composition to hold
several copies of the Muybridge sequence.



5 Select Muybridge_[00-09].tif, and type Cd (Ld) to duplicate it. Drag
it a short distance to the right; your guide will help keep it aligned. (You can also
press S after you start moving a layer to constrain it to the X or Y axis.)

Make five more duplicates, and drag each just beyond the previous copy; there
should be seven layers now. Then create one last duplicate, and while dragging it
to the right, add CS (LS) so it will snap to the right side of the comp. 

6 Type Ca (La) to select all the layers. Open Window > Align & Distribute,
and click on the Horizontal Center Distribution button (bottom row, second from
the right). Close this panel when you’re done, and save your project. 

Nesting the Wide Comp
Next, let’s create a main comp to nest this group of Muybridge sequences into:

7 In the Project panel, select the Comps folder and click the New Comp
button. Set the Preset popup to NTSC DV. Change the duration to 06:00, name
this comp “Figures Main”, and click OK. (Feel free to hide the Parent panel.)

8 To nest a comp, you have two choices: You can drag your first comp into
your new comp, just as you would to add any footage item to a comp.
Alternatively, in the Project panel you can drag the comp
Figures_group on top of the icon for the comp Figures
Main and release the mouse to nest it. After either move,
Figures_group will appear as a single layer in Figures Main.

9 The next step is animating the nested comp to slide
from left to right:

• Select the Figures_group layer; press s to reveal Scale and Sp to reveal
Position. Set the initial Scale value to 50%.

5–6 Create eight copies of the Muybridge
layer, with the left and right ones justified 
to the edges of the comp and the others
roughly spaced in-between (top left). 
Click on the Horizontal Center Distribution
button in Align & Distribute (above), and
they will be evenly spaced (left).

8 To nest one comp into another, you
can just drag it onto the target comp in
the Project panel. It will then appear as a
layer with a comp icon in the target comp.
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9 The Figures_group comp appears as
a single layer when nested so one set of
Position keyframes can be used to move
the eight layers as a group.



• The rulers from step 4 should still be active. Drag down a
guide from the top and place it around Position Y = 50. Then
press Cr (Lr) to hide the rulers.

• Drag the layer so that its right side is aligned with the right
side of the comp and its top snaps to the guide. 

• Enable the stopwatch for Position to create the first
keyframe.

• Press N to go to the end of the comp (at 05:29) and drag
the layer to the right until its left side is aligned with the left
side of the comp. You can use the guide or add the S key
while dragging to keep it at the same height.

RAM Preview. The figures should be marching to the right
(if not, check you didn’t pan the layer in the other direction!).

Editing the Precomp
It is common to call a nested comp a precomp, as it renders first, with its result
included in the master or main comp. Although the main comp appears to get 
a “flattened” layer to work with, the precomp is still live: Any changes you make 
to the precomp will ripple through into the main comp. 

10 O+double-click (A+double-click) on Figures_group to open this nested
comp, or select the Figures_group tab in the Timeline panel. 

11 Let’s stagger the timing of the Muybridge sequences so that the layers are
not all in sync:

• In the Timeline panel, right-click on any column header, and select Columns > In.

• For layer 7, click on the In value, enter –1 in the Layer In Time dialog, and
click OK. The In time will change to -0:00:00:01.
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11–12 In the precomp, offset the In
time of each layer (below) so that they
will appear staggered in time (bottom).
This edit will automatically show up in
the main comp (below right).

9 continued Animate the nested comp to
pan from left to right across its new comp.
(We changed its label color to gold to make
it easier to see its motion path in this figure.) 

� tip
Opening Precomps
To open a nested comp if its tab is not
visible, press O (A) and double-click
the precomp’s layer in the main comp.



• Set the In time for layer 6 to –2. Continue to set each layer one frame earlier
in time, ending at –7 for layer 1.

Each copy of the sequence will now look different. After sliding the layers
earlier, they run out before the end of the comp. In this instance, that’s okay
because the main comp is much shorter than this precomp.

12 Click on the Timeline panel tab for Figures Main to bring it forward, and
RAM Preview. Your staggered timing for the sequence has been automatically
rippled up to this main comp.

Finishing the Project
Congratulations – you’ve completed the major steps (save your project…). 
Here are some ideas for dressing up the final composite; please take artistic 
liberties and use your own sources to create your own design!

13 Locate Sources > Digital Web.mov in the Project panel, and add it as a
background layer to Figures Main.

14 To better match the background, let’s warm up the gray Figures_group
layer plus give it some dimension:

• Select Figures_group and apply Effect > Color Correction > Channel Mixer.
Set to taste; we increased Red-Red to 150 and reduced Blue-Blue to 80. 

• Add Effect > Perspective > Drop Shadow and set to taste. Effects applied to
nested comp layers affect all of the elements in that comp, with the benefit of
having only one set of effects to edit.

15 Now let’s add a lighting treatment: Select Sources > Alien Atmospheres.mov,
and this time add it on top of the other layers in Figures Main. Press $ to
toggle to the Modes panel, and set its mode to Vivid Light. This creates a richer
look, with a tinge of the new layer’s blue color. If you don’t like the blue, apply
Color Correction > Tint: Its default settings will convert the layer to grayscale.
Feel free to try out different modes on both Alien Atmospheres.mov and
Figures_group until you get a blend you like.

16 If you completed Lesson 5, here’s a chance to put your newfound skills to
work! Add a title to this composition, such as “Human Figure in Motion”.
Choose whatever font you think works best (we used a condensed font so that 
it would fit on one line but still be fairly tall), and add Effect > Perspective > 
Drop Shadow to lift it off the background. Then apply a Text Animation Preset,
or create your own design using Text Animators. 

Save your project when you’re done. If you’re curious, our version is
Comps_Finished > Human Main_final.

16 For a final touch, add a text animation
to your composition.
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13–15 Add a background to your main
comp (A), then tint and add a shadow to
the nested precomp (B). Add Alien
Atmospheres on top using Vivid Light
blending mode (C); optionally, convert it
to grayscale to remove the blue tint (D). 

A

B

C

D
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